Install avrdude on Mac OSX Lion

From XinCheJian
Jump to: navigation, search

OSX lion broke a few things with avrdude, but there is a simple fix. You need to have your favorite macports installer done which means you need the latest version of the Mac SDK downloaded (ask paul in person for a copy if you can't find it on your friendly torrent site since they now require you use the appstore to download the 3GB of files needed to install the unix tools ).

I'll assume you're using the super-awesome-brew installer

  • brew install avrdude --with-usb

ok that's the first step but now we need the compilers too, here is a patch for the latest brew install for avr componants (2011-09-26) as it's not been accepted into the brew repo just yet.

done.

--Nihaopaul 18:27, 25 September 2011 (CEST)